Viewing 4 reply threads
  • Author
    Posts
    • #15594
      terrell.bach
      Participant

      My 002a frequency gage runs at full throttle at no more than 56hz. When i adjust the throttle down, the hz will decrease but I won’t go above 56hz with throttle increased to max. The gen set does seem to run slower (less rpm) then prior to this issue. when i push the governor linkage up to increase the rpm the frequency gage does increase as well

      Additionally, i plugged in a palm sander in the convenience outlet and then compared it to plugging in the house AC. It seems to run a bit faster on the house AC.

      Is this a governor issue? Can I adjust the governor to increase the hz? Thx!

    • #15596
      GMG
      Keymaster

      You need to ensure you are using an external meter and not the on-board meters to ensure that you are reading correctly. If there is more slack in the throttle cable, you may need to adjust the cable itself. Lubricate the linkage well and check the entire throttle cable assembly. These cables can break or become frayed.

    • #15605
      terrell.bach
      Participant

      Thanks. I’ve ordered a kill a watt meter to verify. I’ll check the cable however it appears to move in and out. I do know that when its running and i push up on the governor linkage that I can increase the speed to make 60hz.

    • #15606
      terrell.bach
      Participant

      How do you ADJUST the throttle cable?

    • #15613
      terrell.bach
      Participant

      Received my killawatt meter and tested. Issue appears to be both the hz and volt gauges…they’re not accurate. was able to dial in correct hz and voltage and genset runs good. thx for your help!

Viewing 4 reply threads
  • You must be logged in to reply to this topic.